Jump to content

Recommended Posts

Bonjour à tous,

 

J'aimerais savoir si vous rencontrez des difficultés pour exécuter la machine virtuelle contenant Microsoft Dynamics AX, ou ledit logiciel, car dans ma promotion, on s'en sort pas trop.

Demain, ce sera notre dernier cours pour la première partie d'ERP, et nous n'avons pas réussi à exécuter le programme.

 

 

Ma configuration:

Portable         Acer V3-571G

Processeur    Intel Core i3-2370M

Mémoire        8 Go DDR3

Disque dur    500 Go

Système        Windows 7 SP1 / Debian 7.4

 

 

Configuration de mes camarades

Portables      Asus / Acer / Mac

Processeur   Intel (Je ne me souviens pas des références, mais leurs processeurs supportent VT-x)

Mémoire        4 Go à 8 Go

Système        Windows 7 / Windows 8.1 / OS X Mavericks

 

 

Qu'avons nous essayé ?

  • Utiliser Hyper-V de Windows Server 2008 R2 (j'ai installé une VM) : Echec, car impossible d'importer la VM, ou le disque dur
  • Utiliser Hyper-V inclus dans les Windows 8.1 : Importé, mais échec du lancement
  • Utiliser uniquement le disque dur de 112 Go (en passant, assurez-vous que l'ensemble des fichiers soit correct, car la décompression est très longue : -peut prendre plus d'une heure-, et voire qu'un fichier est corrompu à plus de la moitié de la décompression ...) : La machine se lance, mais :
    • La VM va systématiquement consommer la quasi-totalité de la RAM que vous lui fournirez (vérifié avec VMware et VirtualBox sur plusieurs machines hôtes différentes, en fournissant 3 Go, 4 Go, 5 Go, et 5,5 Go)
    • En essayant de fonctionner avec les 3 à 5 % de RAM disponible, on rencontre une erreur qui empêche le programme de continuer à s'exécuter

Si vous réussissez à exécuter MS Dynamics, pouvez-vous me dire comment vous avez fait ?

 

Cordialement,

Share this post


Link to post
Share on other sites

Hello,

De mon côté j'ai réussi à importer la VM dans VMWare Fusion. La première fois ma VM a été corrompue. La seconde fois j'ai réussi :) Cependant comme toi j'ai 100% de CPU et de RAM utilisée.

 

Par contre au bout d'une heure (oui oui, un uptime d'une heure) les services Dynamics ne sont toujours pas lancés (VM avec 4Go de ram et 2 coeurs CPU et sur un SSD). Du coup c'est un peu (beaucoup) flippant.

 

De plus il y a pratiquement 60Go de libre sur la VM alors qu'elle pèse 120Go, si la VM pouvait être refaite en plus "light" ça serait sympa ! :)

Share this post


Link to post
Share on other sites

Bonjour à tous,

 

Concernant la VM voici les configurations utilisées pour la lancer sans encombre.

 

Que ce soit sur VMWare en ayant changer le VHD en tant que VMDK et directement sur Hyper-V.

 

Lors des différents tests nous avons toujours utilisé Hyper-V sur Windows 8.1 Pro concernant la RAM nous avons réussi à descendre jusqu'à 6Go de RAM pour avoir une utilisation correcte (en dessous c'est inutilisable). Pour cela il suffit de brider l'instance SQL Serveur en RAM et de couper les services SharePoint (vous retirant par contre l’accès au roles center). Plus vous avez de RAM disponible mieux vous serez, ce qui semble logique.

 

Concernant le fait de refaire une VM plus light c'est impossible, c'est une VM officielle qui contient l'ensemble des outils nécessaires au bon fonctionnement d'AX (SQL serveur, SharePoint, AD, IIS ...)

 

Je tiens cependant à vous rassurer, comme vos intervenants ont du le faire (je l’espère) l'utilisation de cette VM est un essai pour cette année, elle n'impactera pas vos évaluations (SOE, TP). Vous serez évaluer sur la théorie et vos connaissances des ERP en général (grande partie du cours).

 

Je reste à votre disposition pour de plus amples informations.

Share this post


Link to post
Share on other sites

Bonjour à tous,

 

Je remonte ce sujet car nous commencerons demain la 2ème partie du cours d'ERP, et Microsoft Dynamics est nécessaire pour cette partie. Donc j'aimerais savoir si la désactivation du role center et des services SharePoint ne sera pas bloquante, dans le cas où l'on réussirait effectivement à lancer Dynamics.

Share this post


Link to post
Share on other sites

J'ai réussi à lancer le serveur Dynamics (Ax32Serv.exe) pendant un moment, mais à quel prix :

  • Désactivation de tous les effets aéro et autres (retour en mode Windows Classic avec fond uni)
  • Désactivation de mes logiciels de sécurité (tout cela pour grapiller quelques dizaines de Mo de RAM)
  • Affectation de 8 Go de RAM à la VM (ce qui fait que la VM va forcément swapper, car je n'ai que 8 Go de RAM sur mon portable)

Résultat : Au repos, Ax32Serv utilisait 900 Mo de RAM, mais lors du lancement de Dynamics, j'ai pu observer que le serveur augmentait sa consommation, au point même d'atteindre 2,2 Go de RAM (oui, c'est bien celà, je ne me suis pas trompé). Cette augmentation ne s'est arrêté que parce que j'ai arrêté le serveur via le gestionnaire de tâches.

 

Même si le logiciel s'est lancé après un bon bout de temps (je faisais autre chose en parallèle heureusement), je n'ai pas pu l'utiliser, car la VM (ainsi que ma machine) était trop lente.

 

Maintenant, il faudrait effectivement voir si en désactivant les services SharePoint (ainsi que les pools dans IIS), la VM devient utilisable.

Share this post


Link to post
Share on other sites

Bonjour,

 

Même problème pour ma promo sur le campus de Nice.

Les heureux possesseurs de 8GO de RAM sur leur PC (peu nombreux) arrivent à lancer tant bien que mal Dynamics.

Et quelle lenteur... un clic = une attente de 2 minutes ! Pour faire un exo, ça te ruine la journée (et tes nerfs) !

 

Chez nous, le prof a abandonné depuis très longtemps les quelques démos.... et nous à force on a décroché du cours...

 

Point positif : bossant sur SAP, je comprends maintenant le choix des entreprises, merci Supinfo !!

Share this post


Link to post
Share on other sites

Please sign in to comment

You will be able to leave a comment after signing in



Sign In Now

×