Aller au contenu


Photo

Projet 1LIN 2013-2014: C'est ici !


  • Veuillez vous connecter pour répondre
51 réponses à ce sujet

#21 Samuel CUELLA

Samuel CUELLA

    Curriculum & Faculty Manager

  • Full Professors
  • 226 messages

Posté 09 mai 2014 - 08:36

>je voudrais savoir comment utiliser la dernière version stable du KERNEL pour le projet.

 

Répondre à cette question fait partie de votre projet.

 

>1-S'il vous plait si l'on souhaite utiliser une distribution basée sur les sources, peut -on utiliser debian master, ou même le debian fournit par l'école?

 

Je vous invite à revoir les notions de distribution source/distribution binaire.



#22 Guillaume ORIOL

Guillaume ORIOL

    Newbie

  • Étudiant
  • Pip
  • 1 messages

Posté 13 mai 2014 - 03:23

Bonjour, 

 

j'aimerais installer Plymouth pour avoir une image lors de mon boot, cependant lors de l'installation (emerge plymouth) j'ai un problème avec le package.use (required by sys-boot/plymouth-0.8.8-r4[libkms] j'aurais aimé savoir si quelqu'un a déjà eu ce problème ? 

 

Ou me donner une éventuelle piste pour essayer de corriger ce problème. 

 

Merci



#23 Aymann BLAL

Aymann BLAL

    Member

  • Étudiant
  • PipPip
  • 13 messages
  • Cursus:M.Sc.1

Posté 13 mai 2014 - 03:37

Bonjour, J'ai un problème d'installation de Xorg sur Gentoo.Dans le Gentoo Book il me disent de modifier le kernel mais lors de mon installation j'ai utiliser genkernel all donc il n'y as rien a modifier et lorsque j'ai fait emerege --pv xorg drivers , il me mets un message d'erreurs pour me dire que il y'a des modifications dans mon package.use.Apres modification de mon package.use j'ai des messages d'erreurs "invalid atom in /etc/portage/package.use".

#24 Julien GANDIT

Julien GANDIT

    Newbie

  • Étudiant
  • Pip
  • 5 messages

Posté 13 mai 2014 - 08:10

Bonjour

 

je rencontre un problème lors de la compilation de UME: 

 

/usr/include/SDL/SDL_opengl.h:47:58: erreur fatale: GL/glu.h : Aucun fichier ou dossier de ce type

 
Dans mon /usr/include/GL/ j'ai seulement les fichiers suivants :

glext.h      glxext.h  glx_mangle.h  glxtokens.h  wglext.h

gl.h     glx.h     glxmd.h     internal   wmesa.h

gl_mangle.h  glxint.h  glxproto.h    osmesa.h

 
D'après ce que j'ai pu voir sur Internet, le problème peut se résoudre en installant ibglu1-mesa-dev et mesa-common-dev. Mais je n'arrive pas à trouver les paquets à compiler. Si quelqu'un a rencontré le même problème merci de m'orienter.
 
 
 
Pour info, j'ai résolu le problème en installant GLU.9.0.0 qui contenait le fichier manquant.


#25 Benoit COMPERE

Benoit COMPERE

    Newbie

  • Étudiant
  • Pip
  • 6 messages

Posté 14 mai 2014 - 08:12

Salut à tous! Une fois l'install et le grub réalisés je n'ai plus du tout de réseau sur mon système alors qu'il était détécté automatiquement avec le livecd. Un ifconfig n'affiche que l'interface loopback lo. Quelqu'un a t-il eu ce souci? J'ai suivi plusieurs tuto et visiter plusieurs forums, charger tous les pilotes et modules précisés mais rien n'y fait. Peut etre un souci dans le make menuconfig entre * et M je ne saisis pas totalement quand mettre l'un ou l'autre. Merci beaucoup



#26 Jean Luc Stephane MUSTAPHA

Jean Luc Stephane MUSTAPHA

    Newbie

  • Étudiant
  • Pip
  • 3 messages

Posté 14 mai 2014 - 09:13

Bonjour j'ai eu le même problème que toi, mais j'ai pu le résoudre

d'abord tu fais la commande ls /sys/class/net pour savoir l'interface disponible sur ta machine (soit eth0, eno0, ens1, ...); tu te déplace dans (init.d) tu déclare ton interface disponible au réseau avec ln -s net.lo net.(le nom de ton interface disponible)

ensuite tu l'active avec la commande /etc/init.d/net.(le nom de ton interface) start

enfin pour qu'elle soit activer au démarrage tu effectue la commande rc-update add net.(le nom de ton interface disponible) default.



#27 Jean Luc Stephane MUSTAPHA

Jean Luc Stephane MUSTAPHA

    Newbie

  • Étudiant
  • Pip
  • 3 messages

Posté 14 mai 2014 - 05:22

bonjour

comment faire pour installer le QMC2 après l'avoir décompresser (sur gentoo)? merci



#28 Julien GANDIT

Julien GANDIT

    Newbie

  • Étudiant
  • Pip
  • 5 messages

Posté 15 mai 2014 - 01:59

Bonjour

 

Après avoir compilé UME, j'obtiens l'erreur suivante lorsque j'essai de l'exécuter.

"could not initialize sdl no available video device"

 

Je me suis penché sur les modules du kernel mais je doute que le problème vienne d'un module manquant.

 

Un peu d'aide serait la bienvenue ;-)

 

Merci

 

root@lespros[/sources/ume]#ls /usr/include/SDL/

begin_code.h SDL_error.h SDL_mouse.h SDL_thread.h

close_code.h SDL_events.h SDL_mutex.h SDL_timer.h

SDL_active.h SDL_getenv.h SDL_name.h SDL_ttf.h

SDL_audio.h SDL.h SDL_opengl.h SDL_types.h

SDL_byteorder.h  SDL_joystick.h  SDL_platform.h  SDL_version.h

SDL_cdrom.h SDL_keyboard.h  SDL_quit.h SDL_video.h

SDL_config.h SDL_keysym.h SDL_rwops.h

SDL_cpuinfo.h SDL_loadso.h SDL_stdinc.h

SDL_endian.h SDL_main.h SDL_syswm.h

 

root@lespros[/sources/ume]#ls /dev/

agpgart mapper     stdout  tty34  tty61

autofs mcelog     tty     tty35  tty62

block md0     tty0    tty36  tty63

bsg mem     tty1    tty37  tty7

bus network_latency     tty10   tty38  tty8

cdrom network_throughput  tty11   tty39  tty9

char null     tty12   tty4   ttyS0

console nvram     tty13   tty40  ttyS1

core port     tty14   tty41  ttyS2

cpu ptmx     tty15   tty42  ttyS3

cpu_dma_latency  pts     tty16   tty43  urandom

disk random     tty17   tty44  usbmon0

fd rfkill     tty18   tty45  usbmon1

full rtc     tty19   tty46  usbmon2

hidraw0 rtc0     tty2    tty47  vcs

hpet sda     tty20   tty48  vcs1

initctl sda1     tty21   tty49  vcs2

input sda2     tty22   tty5   vcs3

kmem sda3     tty23   tty50  vcs4

kmsg sda5     tty24   tty51  vcs5

log sequencer     tty25   tty52  vcs6

loop0 sequencer2     tty26   tty53  vcsa

loop1 sg0     tty27   tty54  vcsa1

loop2 sg1     tty28   tty55  vcsa2

loop3 shm     tty29   tty56  vcsa3

loop4 snapshot     tty3    tty57  vcsa4

loop5 snd     tty30   tty58  vcsa5

loop6 sr0     tty31   tty59  vcsa6

loop7 stderr     tty32   tty6   vga_arbiter

loop-control stdin     tty33   tty60  zero



#29 Corentin ZIMMERMANN

Corentin ZIMMERMANN

    Newbie

  • Étudiant
  • Pip
  • 9 messages
  • Cursus:M.Sc.1

Posté 15 mai 2014 - 03:02

Aymann BLAL : "Apres modification de mon package.use j'ai des messages d'erreurs "invalid atom in /etc/portage/package.use" " :
 
Ton ajout dans package.use est donc mal écrit (syntaxe)
 
Jean Luc Stephane MUSTAPHA : "comment faire pour installer le QMC2 après l'avoir décompresser (sur gentoo)? merci"
 
Le compiler ? A noter que sur Gentoo la commande "emerge" permet de télécharger et d'installer qmc2 (pas UME par contre)
 
Julien GANDIT : "Après avoir compilé UME, j'obtiens l'erreur suivante lorsque j'essai de l'exécuter. "could not initialize sdl no available video device" "
 
A priori, c'est que tu lances directement l'éxécutable sans passer par un serveur graphique (la sdl ne trouve pas ton écran)
Si tu restes tout le temps en ligne de commande, la meilleure solution reste de passer ton éxécutable (./ume par exemple) en argument de ce qui peux te permettre de lancer le graphique : Par exemple
 
"startx ./ume" (qui lancera le graphique (si tu l'as installé évidemment) qui lui lancera ton émulateur grâce à la SDL qui cette fois-ci trouvera ton écran.) (ce ne sera pas forcément startx, suivant ce que tu as installé, et donc le passage en argument peut changer aussi)


#30 Geoffrey GRAVALON

Geoffrey GRAVALON

    Newbie

  • Étudiant
  • Pip
  • 5 messages
  • Cursus:M.Sc.1

Posté 16 mai 2014 - 01:02

Hello, quand même une bonne galère pour l'installation ...



#31 Kevin CONTOUX

Kevin CONTOUX

    Member

  • Étudiant
  • PipPip
  • 22 messages

Posté 16 mai 2014 - 05:30

Bonjour,

Quelqu'un sait comment installer QMC2 ? J'ai tenté d'installer QT vu qu'il est nécessaire pour QMC2 à ce que j'ai compris...Mais impossible également...je suis perdu entre QMC2 et QT, leur utilisation, ou trouver les liens de download...

J'en profite pour faire remarquer que sur le campus de Mâcon on a eu nos cours de Linux un peu tard, et je trouve qu'ils n'ont pas grand chose à voir avec projet..ce qui place beaucoup de mes camarades dans l'embarras face à la difficulté du sujet, mais aussi à la documentation/aux tutos dépassés qu'on trouve sur le net...beaucoup de pêle-mêle sur les infos, du coup des débutants en Linux comme moi se retrouve complètement paumés !

Merci d'avance d'une quelconque réponse 



#32 Corentin ZIMMERMANN

Corentin ZIMMERMANN

    Newbie

  • Étudiant
  • Pip
  • 9 messages
  • Cursus:M.Sc.1

Posté 16 mai 2014 - 08:10

Bonjour,

Quelqu'un sait comment installer QMC2 ? J'ai tenté d'installer QT vu qu'il est nécessaire pour QMC2 à ce que j'ai compris...Mais impossible également...je suis perdu entre QMC2 et QT, leur utilisation, ou trouver les liens de download...

J'en profite pour faire remarquer que sur le campus de Mâcon on a eu nos cours de Linux un peu tard, et je trouve qu'ils n'ont pas grand chose à voir avec projet..ce qui place beaucoup de mes camarades dans l'embarras face à la difficulté du sujet, mais aussi à la documentation/aux tutos dépassés qu'on trouve sur le net...beaucoup de pêle-mêle sur les infos, du coup des débutants en Linux comme moi se retrouve complètement paumés !

Merci d'avance d'une quelconque réponse 

Concrètement pour installer il faut :
1) Les sources, 2) les compiler et 3) si tu veux les installer (en gros déplacer les fichiers importants pour lancer ton projet dans d'autres dossiers importants et créer les commandes que tu pourras lancer). L'étape 3 est facultative.
A ce que je comprends tu n'arrives donc pas à compiler ? Qu'as-tu essayé ?
 

 

Hello, quand même une bonne galère pour l'installation ...

 

Souhaiterais-tu nous en faire part ?



#33 Erwan LOCART

Erwan LOCART

    Member

  • Étudiant
  • PipPip
  • 10 messages

Posté 17 mai 2014 - 08:50

Bonjour,

J'ai quelque difficulté a installer UME :

je me base sur : http://www.debian-fr...mc2-t16361.html

Sauf que je ne trouve pas les dépendances suivante : libgtk2.0-dev et libsdl1.2-dev (pour libsdl, j'ai fait un "emerge  libsdl" après un "emerge --search  libsdl" mais je sais pas si c'est les même paquets).

Donc au moment du "make" pour compiler, il y a des erreurs. Finalement ma question est : quels sont les correspondance de paquet pour gentoo ?

J'ai oublier de préciser que j'ai bien changer le "TARGET = emu" dans le makefile.



#34 Hamza ACHBANI

Hamza ACHBANI

    Newbie

  • Étudiant
  • Pip
  • 5 messages
  • Cursus:M.Sc.2

Posté 17 mai 2014 - 09:11

quelqu'un a arrivé à installer UME sur gentoo ?

 

car quand je click sur le .exe de UME que j'ai téléchargé dans gentoo , la vm se redémarre sans rien faire (gentoo sur la VM est trés lent).



#35 Erwan LOCART

Erwan LOCART

    Member

  • Étudiant
  • PipPip
  • 10 messages

Posté 17 mai 2014 - 09:26

quelqu'un a arrivé à installer UME sur gentoo ?

 

car quand je click sur le .exe de UME que j'ai téléchargé dans gentoo , la vm se redémarre sans rien faire (gentoo sur la VM est trés lent).

 

C'est normal, tu a pris un ".exe" qui est pour windows. Pour gentoo (system unix), il faut : .deb / .tar.gz / bz / bzip / bz2 / bzip2 / rpm / et j'en ai surement oublier, les .exe sous linux existe seulement avec wine.



#36 Corentin ZIMMERMANN

Corentin ZIMMERMANN

    Newbie

  • Étudiant
  • Pip
  • 9 messages
  • Cursus:M.Sc.1

Posté 18 mai 2014 - 01:58

Bonjour,

J'ai quelque difficulté a installer UME :

je me base sur : http://www.debian-fr...mc2-t16361.html

Sauf que je ne trouve pas les dépendances suivante : libgtk2.0-dev et libsdl1.2-dev (pour libsdl, j'ai fait un "emerge  libsdl" après un "emerge --search  libsdl" mais je sais pas si c'est les même paquets).

Donc au moment du "make" pour compiler, il y a des erreurs. Finalement ma question est : quels sont les correspondance de paquet pour gentoo ?

J'ai oublier de préciser que j'ai bien changer le "TARGET = emu" dans le makefile.

Fais tes"emerge" en fonction des erreurs que tu as, donc de ce qu'il te manque ;)
 

 

quelqu'un a arrivé à installer UME sur gentoo ?

 

car quand je click sur le .exe de UME que j'ai téléchargé dans gentoo , la vm se redémarre sans rien faire (gentoo sur la VM est trés lent).

Si ce sont les sources qui sont en .exe, le fait est comme Erwan l'a dit, c'est du côté de Windows que ça se passe.
Les sources seront extraits de cet exe, sources que tu pourras ensuite compiler sur ton gentoo.



#37 Erwan LOCART

Erwan LOCART

    Member

  • Étudiant
  • PipPip
  • 10 messages

Posté 18 mai 2014 - 03:38

Et comment vérifier que sont UME fonctionne ?

 

 

Jean Luc Stephane MUSTAPHA : "comment faire pour installer le QMC2 après l'avoir décompresser (sur gentoo)? merci"
 
Le compiler ? A noter que sur Gentoo la commande "emerge" permet de télécharger et d'installer qmc2 (pas UME par contre)

 

 

Et pour QMC2, il faut faire quel emerge ? parcequ'avec emerge --search qmc2, je trouve rien ...



#38 Corentin ZIMMERMANN

Corentin ZIMMERMANN

    Newbie

  • Étudiant
  • Pip
  • 9 messages
  • Cursus:M.Sc.1

Posté 18 mai 2014 - 04:07

Et comment vérifier que sont UME fonctionne ?

 

 

Et pour QMC2, il faut faire quel emerge ? parcequ'avec emerge --search qmc2, je trouve rien ...

En compilant UME, il pourra le lancer, et par conséquent vérifier s'il fonctionne

Pour qmc2, c'est peut-être qu'il n'est pas dans ton arbre de portage (télécharger les sources et le compiler suffisent)



#39 Tianjian ZHANG

Tianjian ZHANG

    Newbie

  • Étudiant
  • Pip
  • 3 messages
  • Cursus:M.Sc.1

Posté 18 mai 2014 - 05:00

Hello,

 

When installing UME in Gentoo Linux, I got an error:

 

collect2: error: ld terminated with signal 9 [Killed]
make: *** [ume] Error 1​
 
This happened after a long time 'compiling' and 'linking ume', using 'make' command.
Could you tell me what the problem is?
Thanks.


#40 Corentin ZIMMERMANN

Corentin ZIMMERMANN

    Newbie

  • Étudiant
  • Pip
  • 9 messages
  • Cursus:M.Sc.1

Posté 18 mai 2014 - 05:13

 

Hello,

 

When installing UME in Gentoo Linux, I got an error:

 

collect2: error: ld terminated with signal 9 [Killed]
make: *** [ume] Error 1​
 
This happened after a long time 'compiling' and 'linking ume', using 'make' command.
Could you tell me what the problem is?
Thanks.

 

The linking phase requires a lot of ram, and the message indicates that it is the system that killed this phase (out of memory so);
How much ram does your VM have ?






1 utilisateur(s) li(sen)t ce sujet

0 membre(s), 1 invité(s), 0 utilisateur(s) anonyme(s)