Aller au contenu


Photo

Swift 2.1 ou 3?


  • Veuillez vous connecter pour répondre
2 réponses à ce sujet

#1 Wadie ABOUIDATE

Wadie ABOUIDATE

    Newbie

  • Étudiant
  • Pip
  • 1 messages
  • Cursus:B.Sc.

Posté 04 décembre 2017 - 01:17

Bonjour

 

J'aimerais savoir si le cours et les Labs sont sur Swift 3(VM Sierra) ou Swift 2.1(VM El-Capitain)?


  • Adam EL IDRISSI JALLAL et Amira FAHEM aiment ceci

#2 Alvin MEIMOUN

Alvin MEIMOUN

    Member

  • Anciens
  • PipPip
  • 143 messages
  • LocationNice
  • Cursus:Alumni

Posté 06 décembre 2017 - 03:08

Bonjour,

 

Xcode 8.x incluant le support de Swift 3 fonctionne à partir de macOS 10.11 El Capitan, tu peu donc prendre n'importe laquelle des deux VM même si je recommande la VM sierra et Xcode 9 qui supporte Swift 3 et 4.

Tu pourras dans tout les cas si le formateur le demande installer en parallèle Xcode 8.


  • Amira FAHEM aime ceci

#3 Amira FAHEM

Amira FAHEM

    Newbie

  • Étudiant
  • Pip
  • 1 messages
  • Cursus:M.Sc.2

Posté 06 décembre 2017 - 10:43

Bonjour Wadie,

 

Le choix de VM est basé sur la compatibilité de votre système il faut vérifier que votre Imac, MacBook, Mac Pro ou Mac mini est bien compatible avec Vm avant l'installation ,selon mon expérience avec développement IOS je vous recommande le VM Sierra parce qu'il support  les différentes versions de Swift avec Xcode9. Bon courage.


  • Wadie ABOUIDATE et Amira FAHEM aiment ceci




0 utilisateur(s) li(sen)t ce sujet

0 membre(s), 0 invité(s), 0 utilisateur(s) anonyme(s)